You ever seen those shows like “Seconds from Disaster” and “Aircrash Investigations” where they show it’s not just one thing that cause a huge catastrophe, it’s actually just a lot of little things that add up to a disaster? That was what my entire day was like today.

Undertaking a linux installation is not something to take lightly and when you have new hardware combined with a new operating system combined with a new version of some important software you have all the elements in place to lose days in front of the computer. What follows is my version of “Seconds from Disaster”.

The disaster started last night when Pauline and I began the installation of Mythtv. The installation of apt went fine and the kernel update gave no errors. But when we rebooted the kernel 2.6.11 would just hang at:

Hardware Initialiation: Storage Network Audio

At that point it should have said [OK] but we never got that far. Luckily I could reboot in to the old kernel which still worked fine. After some research I discovered that Fedora has a history of having trouble booting kernels on an ASUS P4P800 motherboard. Nice to know AFTER I buy the damn thing. But they were all older kernel under 2.6.7 and the bug was supposedly fixed after that. Not many people had complained about the exact issue I was having and anyone who did didn’t have a solution. I went to bed with it stuck in that state.

This morning I decided that since I couldn’t get the latest kernel version working I’d continue on and try to install mythtv. It should have been a simple command that went:

apt-get install mythtv-suite

Instead I got:

The following packages have unmet dependencies:
mythtv: Depends: perl(Net::Server::Fork) but it is not installable
Depends: perl(the) but it is not installable

So I spent a long time searching google and mailing lists to see how to fix it. Fixing the first dependency was a piece of cake – I just installed the perl-Net-Server.rpm, but searching for perl(the) is like looking for the word “me” or “I”. Completely pointless. After a while of not finding anyone with the same problem I decided that my install of Fedora was dodgy as I had had some issues with disc 2.

So I began the whole process of installing Fedora again. The install went ok but when I rebooted the screen went dodgy and couldn’t find specific files. So I restarted it again and the pc went in to a loop where the bios would just keep restarting in a perpetual loop. At that point Pauline and I decided that the ATI Radeon 9600 card was faulty and swapped it with Ti4200 card we had. The pc seemed to settle down then so I reinstalled Fedora AGAIN. This time the cds weren’t being read partway through the installation and then giving I/O errors so I pulled the damn DVD Drive out and replaced it with a CD Rom drive. The install finally completed. In the middle of all this I had people from the Church of Latter Day Saints visiting the front door and by god, if they had a fix for my problems I would have converted on the spot!

I thought that maybe my original Fedora install may have caused the kernel errors but they were still happening on the new install. The mythtv errors were also the same, so the whole process was a waste of time. Around about 7pm I discovered that the mythtv install I was using was only put there the day before so I suspected that maybe there was an issue. I sent an email to the mailing list and while waiting for my mail to appear I noticed that some other people had sent emails with the same issue. Apparently it was a known bug and would be fixed today.

So basically I’m in the same place where I started, but with a whole day wasted. How the hell was I supposed to troubleshoot my install when I had two pieces of hardware that were broken and one motherboard that has kernel issues? Computers are good when they work, but when they don’t they are f*()*(&*ing sh**!



3 thoughts on “New motherboard hell

  1. Amyo says:

    Hmm, looks like I was too quick to blame the motherboard. This morning I had a brainwave and realised it was actually my tv tuner card that was forcing kernel 2.6.11 to fail. Apparently it is a known issue with the Twinhan Visionplus cards. I’m currently installing 2.6.10 which is *supposed* to work. At least mythtv is installed now thanks to them fixing the package. More updates as it happens because this is such a compelling subject. 😉

  2. Amyo says:

    2.6.10 didn’t work either so I’ve stayed with 2.6.9. The card worked with this kernel so I’ll stick with it for now. Once the mythtv files were fixed the install went efortlessly – much easier than the first time I installed myth. You have to love apt-get. I’ve now got mythtv working with all it’s new bells and whistles and even have a frontend on my powerbook so I can watch tv on my laptop. Next up I need to get the frontend working on the xbox, but they need to be updated to myth 0.18 first.

  3. mib says:

    Careful Amy you could have your title of ‘Geek’ stripped away with a blob like this. This is the frustration that geeks live for. If it was easy everyone could do it and how would we know who is a geek? 😉


Leave a Reply